import re
regex = re.compile(r"{[a-z]+:ce_img:(?:single|pair)?([\w\W\s]+)*}")
test_str = ("{eggs:ce_img:single \n"
" src=\"{src}\"\n"
" fallback_src=\"/assets/a-b-c.jpg\"\n"
" width=\"250\"\n"
" height=\"250\"\n"
" add_dims=\"no\"\n"
" crop=\"yes\"\n"
" title=\"{title}\"\n"
" alt=\"{title}\"\n"
" allow_scale_larger=\"yes\"\n"
"}")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)