#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((.|\n)*)(\n)^(.*)$\z"
Local $sString = "S" & @CRLF & _
" T" & @CRLF & _
" A" & @CRLF & _
" R" & @CRLF & _
" M" & @CRLF & _
" A" & @CRLF & _
" D" & @CRLF & _
" E"
Local $sSubst = "$4\n$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)