const regex = /(?m)((.|\n)*)(\n)^(.*)$\z/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)((.|\\n)*)(\\n)^(.*)$\\z', 'g')
const str = `S
T
A
R
M
A
D
E`;
const subst = `$4\n$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);