re = /(?m)((.|\n)*)(\n)^(.*)$\z/
str = 'S
T
A
R
M
A
D
E'
subst = '$4\\n$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result