use strict;
my $str = 'S
T
A
R
M
A
D
E';
my $regex = qr/(?m)((.|\n)*)(\n)^(.*)$\z/p;
my $subst = '$4\\n$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";