import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)((.|\\n)*)(\\n)^(.*)$\\z";
final String string = "S\n"
+ " T\n"
+ " A\n"
+ " R\n"
+ " M\n"
+ " A\n"
+ " D\n"
+ " E";
final String subst = "$4\\n$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}