$re = '/(?m)((.|\n)*)(\n)^(.*)$\z/';
$str = 'S
T
A
R
M
A
D
E';
$subst = "$4\n$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;