using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)((.|\n)*)(\n)^(.*)$\z";
string substitution = @"$4\n$1";
string input = @"S
T
A
R
M
A
D
E";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}