#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)\b(Fat(\W?|\W?\b.*\b)(Bike|Trike))\b"
Local $sString = "My father's fat bike is a fat tyre bike." & @CRLF & _
"My father's fat-bike is a fat tyre bike." & @CRLF & _
"My father's Fat Tyre Electric Bike." & @CRLF & _
"My father's fat-bike." & @CRLF & _
"My father's fat, bike." & @CRLF & _
"My father's fat, tyre, bike." & @CRLF & _
"My father's fat, tyre, electric-bike." & @CRLF & _
"My father's fat, tyre, electric bike." & @CRLF & _
"My father's fat, tyre. Electric bike." & @CRLF & _
"My father's fat-tyre, electric bike." & @CRLF & _
"My father's fat, tyre, electric Trike." & @CRLF & _
"#FatBike" & @CRLF & _
"#Fat-Bike" & @CRLF & _
"#Fat-Tyre-Bike" & @CRLF & _
"#FatTrike" & @CRLF & _
"My father's fat motorbike." & @CRLF & _
"My father's fat tyre motorbike." & @CRLF & _
"My father's lefat tyre electric bike." & @CRLF & _
"My father's fat tyre electric biker." & @CRLF & _
"My father's fat1 tyre, electric bike." & @CRLF & _
"My father's fatt tyre, electric bike." & @CRLF & _
"#FatTyreBike" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")