package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\b(Fat(\W?|\W?\b.*\b)(Bike|Trike))\b`)
var str = `My father's fat bike is a fat tyre bike.
My father's fat-bike is a fat tyre bike.
My father's Fat Tyre Electric Bike.
My father's fat-bike.
My father's fat, bike.
My father's fat, tyre, bike.
My father's fat, tyre, electric-bike.
My father's fat, tyre, electric bike.
My father's fat, tyre. Electric bike.
My father's fat-tyre, electric bike.
My father's fat, tyre, electric Trike.
#FatBike
#Fat-Bike
#Fat-Tyre-Bike
#FatTrike
My father's fat motorbike.
My father's fat tyre motorbike.
My father's lefat tyre electric bike.
My father's fat tyre electric biker.
My father's fat1 tyre, electric bike.
My father's fatt tyre, electric bike.
#FatTyreBike
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}