const regex = /\b(Fat(\W?|\W?\b.*\b)(Bike|Trike))\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(Fat(\\W?|\\W?\\b.*\\b)(Bike|Trike))\\b', 'gmi')
const str = `My father's fat bike is a fat tyre bike.
My father's fat-bike is a fat tyre bike.
My father's Fat Tyre Electric Bike.
My father's fat-bike.
My father's fat, bike.
My father's fat, tyre, bike.
My father's fat, tyre, electric-bike.
My father's fat, tyre, electric bike.
My father's fat, tyre. Electric bike.
My father's fat-tyre, electric bike.
My father's fat, tyre, electric Trike.
#FatBike
#Fat-Bike
#Fat-Tyre-Bike
#FatTrike
My father's fat motorbike.
My father's fat tyre motorbike.
My father's lefat tyre electric bike.
My father's fat tyre electric biker.
My father's fat1 tyre, electric bike.
My father's fatt tyre, electric bike.
#FatTyreBike
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}