using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(Fat(\W?|\W?\b.*\b)(Bike|Trike))\b";
string input = @"My father's fat bike is a fat tyre bike.
My father's fat-bike is a fat tyre bike.
My father's Fat Tyre Electric Bike.
My father's fat-bike.
My father's fat, bike.
My father's fat, tyre, bike.
My father's fat, tyre, electric-bike.
My father's fat, tyre, electric bike.
My father's fat, tyre. Electric bike.
My father's fat-tyre, electric bike.
My father's fat, tyre, electric Trike.
#FatBike
#Fat-Bike
#Fat-Tyre-Bike
#FatTrike
My father's fat motorbike.
My father's fat tyre motorbike.
My father's lefat tyre electric bike.
My father's fat tyre electric biker.
My father's fat1 tyre, electric bike.
My father's fatt tyre, electric bike.
#FatTyreBike
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}