$re = '/\b(Fat(\W?|\W?\b.*\b)(Bike|Trike))\b/mi';
$str = 'My father\'s fat bike is a fat tyre bike.
My father\'s fat-bike is a fat tyre bike.
My father\'s Fat Tyre Electric Bike.
My father\'s fat-bike.
My father\'s fat, bike.
My father\'s fat, tyre, bike.
My father\'s fat, tyre, electric-bike.
My father\'s fat, tyre, electric bike.
My father\'s fat, tyre. Electric bike.
My father\'s fat-tyre, electric bike.
My father\'s fat, tyre, electric Trike.
#FatBike
#Fat-Bike
#Fat-Tyre-Bike
#FatTrike
My father\'s fat motorbike.
My father\'s fat tyre motorbike.
My father\'s lefat tyre electric bike.
My father\'s fat tyre electric biker.
My father\'s fat1 tyre, electric bike.
My father\'s fatt tyre, electric bike.
#FatTyreBike
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);