import Foundation
let pattern = #"\b(Fat(\W?|\W?\b.*\b)(Bike|Trike))\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
My father's fat bike is a fat tyre bike.
My father's fat-bike is a fat tyre bike.
My father's Fat Tyre Electric Bike.
My father's fat-bike.
My father's fat, bike.
My father's fat, tyre, bike.
My father's fat, tyre, electric-bike.
My father's fat, tyre, electric bike.
My father's fat, tyre. Electric bike.
My father's fat-tyre, electric bike.
My father's fat, tyre, electric Trike.
#FatBike
#Fat-Bike
#Fat-Tyre-Bike
#FatTrike
My father's fat motorbike.
My father's fat tyre motorbike.
My father's lefat tyre electric bike.
My father's fat tyre electric biker.
My father's fat1 tyre, electric bike.
My father's fatt tyre, electric bike.
#FatTyreBike
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)