#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\`{3}[\w|\W]+?\`{3})"
Local $sString = " ``` " & @CRLF & _
" block code " & @CRLF & _
" word1" & @CRLF & _
" word2" & @CRLF & _
" ```" & @CRLF & _
"" & @CRLF & _
"word without grave accent and it is will match it too" & @CRLF & _
"" & @CRLF & _
" ```" & @CRLF & _
" another block code" & @CRLF & _
" word1" & @CRLF & _
" word2" & @CRLF & _
" - it's will match it as part of the first block code" & @CRLF & _
" ```" & @CRLF & _
"" & @CRLF & _
""""" & @CRLF & _
"some text after the grave accent text" & @CRLF & _
"word1" & @CRLF & _
"word2" & @CRLF & _
""""`"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")