import re
regex = re.compile(r"(\`{3}[\w|\W]+?\`{3})", flags=re.MULTILINE)
test_str = (" ``` \n"
" block code \n"
" word1\n"
" word2\n"
" ```\n\n"
"word without grave accent and it is will match it too\n\n"
" ```\n"
" another block code\n"
" word1\n"
" word2\n"
" - it's will match it as part of the first block code\n"
" ```\n\n"
"\"\"\"\n"
"some text after the grave accent text\n"
"word1\n"
"word2\n"
"\"\"\"`")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")