package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\`{3}[\w|\W]+?\`{3})`)
var str = ` \`\`\`
block code
word1
word2
\`\`\`
word without grave accent and it is will match it too
\`\`\`
another block code
word1
word2
- it's will match it as part of the first block code
\`\`\`
"""
some text after the grave accent text
word1
word2
"""\``
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}