const regex = /(\`{3}[\w|\W]+?\`{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\`{3}[\\w|\\W]+?\\`{3})', 'gm')
const str = ` \`\`\`
block code
word1
word2
\`\`\`
word without grave accent and it is will match it too
\`\`\`
another block code
word1
word2
- it's will match it as part of the first block code
\`\`\`
"""
some text after the grave accent text
word1
word2
"""\``;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}