$re = '/(\`{3}[\w|\W]+?\`{3})/m';
$str = ' ```
block code
word1
word2
```
word without grave accent and it is will match it too
```
another block code
word1
word2
- it\'s will match it as part of the first block code
```
"""
some text after the grave accent text
word1
word2
"""`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);