#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:END.*|.*?START)(*SKIP)(*F)|\d+"
Local $sString = "123,45678,789,777,888,1234" & @CRLF & _
"123,START,789,777,888,1234" & @CRLF & _
"123,45678,789,777,END,1234" & @CRLF & _
"123,START,789,777,END,1234" & @CRLF & _
"123,END,789,777,START,1234" & @CRLF & _
"123,START,789,START,777,END,1234" & @CRLF & _
"123,START,789,END,777,END,1234" & @CRLF & _
"123,END,789,START,777,END,1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")