$re = '/(?:END.*|.*?START)(*SKIP)(*F)|\d+/m';
$str = '123,45678,789,777,888,1234
123,START,789,777,888,1234
123,45678,789,777,END,1234
123,START,789,777,END,1234
123,END,789,777,START,1234
123,START,789,START,777,END,1234
123,START,789,END,777,END,1234
123,END,789,START,777,END,1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);