import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:END.*|.*?START)(*SKIP)(*F)|\\d+";
final String string = "123,45678,789,777,888,1234\n"
+ "123,START,789,777,888,1234\n"
+ "123,45678,789,777,END,1234\n"
+ "123,START,789,777,END,1234\n"
+ "123,END,789,777,START,1234\n"
+ "123,START,789,START,777,END,1234\n"
+ "123,START,789,END,777,END,1234\n"
+ "123,END,789,START,777,END,1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}