package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:END.*|.*?START)(*SKIP)(*F)|\d+`)
var str = `123,45678,789,777,888,1234
123,START,789,777,888,1234
123,45678,789,777,END,1234
123,START,789,777,END,1234
123,END,789,777,START,1234
123,START,789,START,777,END,1234
123,START,789,END,777,END,1234
123,END,789,START,777,END,1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}