# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:END.*|.*?START)(*SKIP)(*F)|\d+"
test_str = ("123,45678,789,777,888,1234\n"
"123,START,789,777,888,1234\n"
"123,45678,789,777,END,1234\n"
"123,START,789,777,END,1234\n"
"123,END,789,777,START,1234\n"
"123,START,789,START,777,END,1234\n"
"123,START,789,END,777,END,1234\n"
"123,END,789,START,777,END,1234")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.