using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:END.*|.*?START)(*SKIP)(*F)|\d+";
string input = @"123,45678,789,777,888,1234
123,START,789,777,888,1234
123,45678,789,777,END,1234
123,START,789,777,END,1234
123,END,789,777,START,1234
123,START,789,START,777,END,1234
123,START,789,END,777,END,1234
123,END,789,START,777,END,1234";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}