re = /(?:END.*|.*?START)(*SKIP)(*F)|\d+/m
str = '123,45678,789,777,888,1234
123,START,789,777,888,1234
123,45678,789,777,END,1234
123,START,789,777,END,1234
123,END,789,777,START,1234
123,START,789,START,777,END,1234
123,START,789,END,777,END,1234
123,END,789,START,777,END,1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end