use strict;
my $str = '123,45678,789,777,888,1234
123,START,789,777,888,1234
123,45678,789,777,END,1234
123,START,789,777,END,1234
123,END,789,777,START,1234
123,START,789,START,777,END,1234
123,START,789,END,777,END,1234
123,END,789,START,777,END,1234';
my $regex = qr/(?:END.*|.*?START)(*SKIP)(*F)|\d+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}