#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "( *?https{0,1}:\/\/w{0,3}.*| *?ftp:\/\/w{0,3}.*| *?\n)"
Local $sString = "http://www.abcd.com.br" & @CRLF & _
"https://pt.stackoverflow.com/questions/79908/validar-url-express%C3%A3o-regular" & @CRLF & _
"ftp://algumacoisa.aqui.jap" & @CRLF & _
"eu não sou uma URL" & @CRLF & _
"ftp://www. eu tenho espaços em branco . com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")