import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "( *?https{0,1}:\\/\\/w{0,3}.*| *?ftp:\\/\\/w{0,3}.*| *?\\n)";
final String string = "http://www.abcd.com.br\n"
+ "https://pt.stackoverflow.com/questions/79908/validar-url-express%C3%A3o-regular\n"
+ "ftp://algumacoisa.aqui.jap\n"
+ "eu não sou uma URL\n"
+ "ftp://www. eu tenho espaços em branco . com\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}