const regex = /( *?https{0,1}:\/\/w{0,3}.*| *?ftp:\/\/w{0,3}.*| *?\n)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('( *?https{0,1}:\\\/\\\/w{0,3}.*| *?ftp:\\\/\\\/w{0,3}.*| *?\\n)', 'g')
const str = `http://www.abcd.com.br
https://pt.stackoverflow.com/questions/79908/validar-url-express%C3%A3o-regular
ftp://algumacoisa.aqui.jap
eu não sou uma URL
ftp://www. eu tenho espaços em branco . com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}