// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"( *?https{0,1}:\/\/w{0,3}.*| *?ftp:\/\/w{0,3}.*| *?\n)").unwrap();
let string = "http://www.abcd.com.br
https://pt.stackoverflow.com/questions/79908/validar-url-express%C3%A3o-regular
ftp://algumacoisa.aqui.jap
eu não sou uma URL
ftp://www. eu tenho espaços em branco . com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}