# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"( *?https{0,1}:\/\/w{0,3}.*| *?ftp:\/\/w{0,3}.*| *?\n)"
test_str = ("http://www.abcd.com.br\n"
"https://pt.stackoverflow.com/questions/79908/validar-url-express%C3%A3o-regular\n"
"ftp://algumacoisa.aqui.jap\n"
"eu não sou uma URL\n"
"ftp://www. eu tenho espaços em branco . com\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.