using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"( *?https{0,1}:\/\/w{0,3}.*| *?ftp:\/\/w{0,3}.*| *?\n)";
string input = @"http://www.abcd.com.br
https://pt.stackoverflow.com/questions/79908/validar-url-express%C3%A3o-regular
ftp://algumacoisa.aqui.jap
eu não sou uma URL
ftp://www. eu tenho espaços em branco . com
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}