use strict;
my $str = 'http://www.abcd.com.br
https://pt.stackoverflow.com/questions/79908/validar-url-express%C3%A3o-regular
ftp://algumacoisa.aqui.jap
eu não sou uma URL
ftp://www. eu tenho espaços em branco . com
';
my $regex = qr/( *?https{0,1}:\/\/w{0,3}.*| *?ftp:\/\/w{0,3}.*| *?\n)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}