$re = '/( *?https{0,1}:\/\/w{0,3}.*| *?ftp:\/\/w{0,3}.*| *?\n)/';
$str = 'http://www.abcd.com.br
https://pt.stackoverflow.com/questions/79908/validar-url-express%C3%A3o-regular
ftp://algumacoisa.aqui.jap
eu não sou uma URL
ftp://www. eu tenho espaços em branco . com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);