# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[ame=[^\]]*\])(.*?)(\[\\/ame\])/$1$3/gm;t' <<< "[ame=\"http://www.google.com\"]Google - a search engine[/ame]"