using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[ame=[^\]]*\])(.*?)(\[\/ame\])";
string substitution = @"$1$3";
string input = @"[ame=""http://www.google.com""]Google - a search engine[/ame]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}