package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\[ame=[^\]]*\])(.*?)(\[\/ame\])`)
var str = `[ame="http://www.google.com"]Google - a search engine[/ame]`
var substitution = "$1$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}