$re = '/(\[ame=[^\]]*\])(.*?)(\[\/ame\])/m';
$str = '[ame="http://www.google.com"]Google - a search engine[/ame]';
$subst = "$1$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;