#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\[ame=[^\]]*\])(.*?)(\[\/ame\])"
Local $sString = "[ame="http://www.google.com"]Google - a search engine[/ame]"
Local $sSubst = "$1$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)