use strict;
my $str = '[ame="http://www.google.com"]Google - a search engine[/ame]';
my $regex = qr/(\[ame=[^\]]*\])(.*?)(\[\/ame\])/mp;
my $subst = '$1$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";