// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\[ame=[^\]]*\])(.*?)(\[\/ame\])").unwrap();
let string = "[ame=\"http://www.google.com\"]Google - a search engine[/ame]";
let substitution = "$1$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}