re = /(\[ame=[^\]]*\])(.*?)(\[\/ame\])/m
str = '[ame="http://www.google.com"]Google - a search engine[/ame]'
subst = '$1$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result