# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(:.*|[^:]*)$//gm;t' <<< "Element 1 | Element 2| Element 3: element 4
Element 1 | Element 2| Element 3 element 4"