#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(:.*|[^:]*)$"
Local $sString = "Element 1 | Element 2| Element 3: element 4" & @CRLF & _
"Element 1 | Element 2| Element 3 element 4"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)