$re = '/(:.*|[^:]*)$/m';
$str = 'Element 1 | Element 2| Element 3: element 4
Element 1 | Element 2| Element 3 element 4';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;