use strict;
my $str = 'Element 1 | Element 2| Element 3: element 4
Element 1 | Element 2| Element 3 element 4';
my $regex = qr/(:.*|[^:]*)$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";