re = /(:.*|[^:]*)$/m
str = 'Element 1 | Element 2| Element 3: element 4
Element 1 | Element 2| Element 3 element 4'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result