package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(:.*|[^:]*)$`)
var str = `Element 1 | Element 2| Element 3: element 4
Element 1 | Element 2| Element 3 element 4`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}