using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(:.*|[^:]*)$";
string substitution = @"";
string input = @"Element 1 | Element 2| Element 3: element 4
Element 1 | Element 2| Element 3 element 4";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}